Section courante

A propos

Section administrative du site

apt-get

Une demande de paquet
Linux Externe

Syntaxe

apt-get [ -hvs ] [ -o=config string ] [ -c=file ] { update | upgrade | dselect-upgrade | install pkg ... | remove pkg ... | source pkg ... | build-dep pkg ... | check | clean | autoclean }

Paramètres

Nom Description
--assume-yes Ce paramètre permet d'indiquer qu'il faut automatiquement répondre par oui à toutes les questions de prompt.
autoclean Ce paramètre permet d'indiquer qu'il faut uniquement effacer la référence local des paquets récupérés ne pouvant plus être téléchargé.
-b Ce paramètre permet de compiler les paquets de source après le téléchargement de celui-ci.
--build Ce paramètre permet de compiler les paquets de source après le téléchargement de celui-ci.
build-dep package1 [package2] [...] Ce paramètre permet d'indiquer qu'il installer ou enlever des paquets afin de satisfaire les dépendances de construction pour une source de paquets spécifiés.
-c Ce paramètre permet d'indiquer qu'il faut effectuer la configuration du fichier.
check Ce paramètre permet d'indiquer qu'il faut effectuer une mise à jour du cache de dépendances et vérifier les dépendances cassés.
clean Ce paramètre permet d'indiquer qu'il faut effacer la référence local des paquets récupérés.
--compile Ce paramètre permet de compiler les paquets de source après le téléchargement de celui-ci.
--config-file Ce paramètre permet d'indiquer qu'il faut effectuer la configuration du fichier.
-d Ce paramètre permet d'uniquement effectué le téléchargement des fichiers du paquets, sans le dépaqueté ou l'installé.
dist-upgrade package1 [package2] [...] Ce paramètre permet d'indiquer qu'il faut mettre à niveau et gérer intelligemment les dépendances avec les nouvelles versions de paquets.
-d Ce paramètre permet d'uniquement effectué le téléchargement des fichiers du paquets, sans le dépaqueté ou l'installé.
--default-release Ce paramètre permet de contrôler l'entrée par défaut pour le moteur de politique.
--download-only Ce paramètre permet d'uniquement effectué le téléchargement des fichiers du paquets, sans le dépaqueté ou l'installé.
--dry-run Ce paramètre permet d'indiquer qu'il faut effectuer une simulation rien changer dans le système.
-f Ce paramètre permet d'essayer de corriger un système possédant des dépendances défectueuses.
--fix-broken Ce paramètre permet d'essayer de corriger un système possédant des dépendances défectueuses.
--fix-missing Ce paramètre permet d'indiquer qu'il faut ignorer les paquets manquants.
--force-yes Ce paramètre permet de forcer a utiliser la réponse «Oui» à chacune des questions sur le prompt. Ce paramètre est extrêmement dangereux, une mauvaise utilisation, peut détruire le système.
-h Ce paramètre permet d'afficher l'utilisation d'un court sommaire d'aide.
--help Ce paramètre permet d'afficher l'utilisation d'un court sommaire d'aide.
--ignore-hold Ce paramètre permet d'indiquer qu'il faut ignorer les paquets retenues à placé dans un paquet.
--ignore-missing Ce paramètre permet d'indiquer qu'il faut ignorer les paquets manquants.
install package1 [package2] [...] Ce paramètre permet d'installer le paquet spécifié.
--just-print Ce paramètre permet d'indiquer qu'il faut effectuer une simulation rien changer dans le système.
--list-cleanup Ce paramètre permet de gérer automatiquement les contenus de /var/lib/apt/lists afin de s'assurer que les fichiers obsolètes seront écrasées.
-m Ce paramètre permet d'indiquer qu'il faut ignorer les paquets manquants.
--no-act Ce paramètre permet d'indiquer qu'il faut effectuer une simulation rien changer dans le système.
--no-download Ce paramètre permet de désactiver le téléchargement de paquets.
--no-remove Ce paramètre permet d'indiquer qu'il faut annuler l'opération dès qu'il faut enlever un paquet.
--no-upgrade Ce paramètre permet de mettre à niveau les paquets.
-o Ce paramètre permet de fixer une option de configuration.
--only-source Ce paramètre permet d'indiquer que les noms des sources de données ne doivent pas être repérés à travers la table binaire.
--option Ce paramètre permet de fixer une option de configuration.
--print-uris Ce paramètre permet d'indiquer qu'au lieu d'aller chercher les paquets à installer, il faut affiché les URI.
-q Ce paramètre permet d'indiquer qu'il faut uniquement afficher les informations de suivi en omettant les indicateurs de progression.
--quiet Ce paramètre permet d'indiquer qu'il faut uniquement afficher les informations de suivi en omettant les indicateurs de progression.
--recon Ce paramètre permet d'indiquer qu'il faut effectuer une simulation rien changer dans le système.
--reinstall Ce paramètre permet de réinstaller les paquets étant déjà installé et à la dernière version.
remove package1 [package2] [...] Ce paramètre permet de supprimer le paquet spécifié.
-s Ce paramètre permet d'indiquer qu'il faut effectuer une simulation rien changer dans le système.
--show-upgraded Ce paramètre permet d'afficher les modules de mise à niveau.
--simulate Ce paramètre permet d'indiquer qu'il faut effectuer une simulation rien changer dans le système.
source package1 [package2] [...] Ce paramètre permet d'indiquer qu'il faut uniquement récupérer les sources des paquets.
-t Ce paramètre permet de contrôler l'entrée par défaut pour le moteur de politique.
--target-release Ce paramètre permet de contrôler l'entrée par défaut pour le moteur de politique.
--trivial-only Ce paramètre permet d'uniquement effectuer les opérations en «trivial».
-u Ce paramètre permet d'afficher les modules de mise à niveau.
update package1 [package2] [...] Ce paramètre permet d'indiquer qu'il faut synchroniser les fichiers d'index de paquets avec leurs sources.
upgrade package1 [package2] [...] Ce paramètre permet d'indiquer qu'il faut installer la nouvelle version de tous les paquests actuellements installés dans le système de source énumérés dans «/etc/apt/sources.list».
-v Ce paramètre permet d'afficher la version du programme.
-V Ce paramètre permet d'afficher toutes les détails de la version pour le mise à niveau et l'installation des paquets.
--verbose-versions Ce paramètre permet d'afficher toutes les détails de la version pour le mise à niveau et l'installation des paquets.
--version Ce paramètre permet d'afficher la version du programme.
-y Ce paramètre permet d'indiquer qu'il faut automatiquement répondre par oui à toutes les questions de prompt.
--yes Ce paramètre permet d'indiquer qu'il faut automatiquement répondre par oui à toutes les questions de prompt.

Description

Cette commande permet d'effectuer l'installation de paquet ou de module à partir d'un dépôt.

Remarques

Exemples

L'exemple suivant permet d'installer «Apache» lorsqu'on en root (droits d'accès administrateur) :

apt-get install apache

L'exemple suivant permet d'installer «NASM» en combinant la commande «sudo» laquelle permet d'utiliser les droits d'accès administrateur :

sudo apt-get install nasm

L'exemple suivant permet d'installer MemCache sous PHP5 sous une distribution Linux comme Ubuntu :

sudo apt-get install php5-memcache


Dernière mise à jour : Jeudi, le 1er janvier 2015